[Problem]To Build with Flash Develop

pb221201's Avatar


25 Nov, 2009 05:23 AM

Hi , first of all i want to give my thanks to the project owners and their hard work !! Thank you very much !!
In fact i have studied a lot the pureMVC , however when i saw the release of Robotlegs , i decided to change the

Well, and there is a problem i found when i wanted to build the HelloFlash example , in my FD it says it can't found the
parent class (of Injector and Reflector) and i can't figure out why ~~ T_T , so i don't know if someone has happened the same or
give me some suggestion , i have also done a snap of the screen for show the problem , i have included and add to the library the
swcs and i also included the robotlegs source to the project for build from the source and seems it didn't work....

Thx again!

  1. Support Staff 1 Posted by creynders on 25 Nov, 2009 08:43 AM

    creynders's Avatar

    I think either you have to add the lib folder as a classpath to your project: 'Project' > 'Properties' > 'Classpaths' tab > 'add classpath'
    or you have to add the source files to swiftsuspender to your src folder
    (get it from http://github.com/tschneidereit/SwiftSuspenders)

  2. Support Staff 2 Posted by Till Schneidere... on 25 Nov, 2009 09:17 AM

    Till Schneidereit's Avatar

    As creynders says, it should be enough to add the Robotlegs swc to the
    classpath. Try removing both the Robotlegs source and the
    SwiftSuspenders swc (the latter is included in the Robotlegs swc, so
    no need to have it around, too).

    If you want to keep using the source, on the other hand, you don't
    need the swcs. What you do need to do, then, is to add two parameters
    to your mxmlc config, as described under "Installation" in the
    SwiftSuspenders README:

    I don't work with FlashDevelop, so unfortunately I can't tell you how
    to add these parameters, but I guess it's not too hard.

  3. Support Staff 3 Posted by creynders on 25 Nov, 2009 10:24 AM

    creynders's Avatar

    Ah, right i had forgotten about the extra compiler arguments. Again :)
    In FD (if I remember correctly) you can add the arguments by going to 'Project' > 'Properties' > 'Compiler Options' tab and click on the 'String[] Array' next to 'Additional Compiler options'. Paste '-keep-as3-metadata+=Inject'

  4. 4 Posted by pb221201 on 25 Nov, 2009 04:35 PM

    pb221201's Avatar

    i have tried to remove all swc and build with the sources , it sucessed!!
    however either i add the class path and paste the "-keep-as3-metadata+=Inject"
    it appears the wrongs that can't find the Context Class base and the startup method doesn't exist ( i add the class path and add them to the library , in the FD it detects it existence , when i coded , appeared the code completion and the Context class name has been colored , just in the compile time it says it didnt' be found).

    Anyway i can build with the src files , and not swcs , in fact i don't know the diference , is there any optimization to use the swc ?? or is the same to work with src files ??

    Thx ur attetions !!

  5. Support Staff 5 Posted by Joel Hooks on 25 Nov, 2009 04:49 PM

    Joel Hooks's Avatar

    The swc just makes it a little easier. You don't need the compiler argument and SwiftSuspenders is compiled in. No optimization.

  6. 6 Posted by pb221201 on 25 Nov, 2009 07:52 PM

    pb221201's Avatar

    MM, ok , just the same , includes the src files didn't a big work , thx Joel , ur reply
    : )

  7. 7 Posted by pb221201 on 29 Nov, 2009 04:46 AM

    pb221201's Avatar

    Hey !

    I have download the robotlegs 1.0 and use it swc with the FD project ,
    now it works perfectly , i think i have bad configured the project , this
    post can be closed , thx to anyone :) !!

  8. Joel Hooks closed this discussion on 29 Nov, 2009 04:52 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac