Variable IInjector is not defined

creynders's Avatar


11 Oct, 2010 05:08 PM

I'm creating an app with GAIA & RobotLegs. I followed Jesse Warden's Robotlegs on top of Gaia (part deux) but changed a couple of things because in his example all Robotlegs code and also RL-dependent application code is compiled in the main.swf file (the primary file)
So I created an index file (which also exports as .swc) and let it set up the application context for RL, it has linked the robotlegs.swc as a library and if i inspect the contetns of index.swf it contains all RL classes (just as it should).
However if I compile all files and run main, I get the following error:

ReferenceError: Error #1065: Variable IInjector is not defined.
at flash.system::ApplicationDomain/getDefinition()

So clearly it's an applicationdomain problem, but since i defined the domain='current'in the site.xml file I thought all swf files would be loaded in the same application domain?
Anybody got an idea how to fix this? And is this something that needs to happen Gaia-side or RL-side?

  1. Support Staff 1 Posted by Shaun Smith on 01 Nov, 2010 10:49 PM

    Shaun Smith's Avatar

    Hi Camille,

    Are you still having problems with this? If so, have you tried the latest version of Robotlegs (v1.3.0)? v1.3.0 has better support for application domains.

  2. Support Staff 2 Posted by creynders on 02 Nov, 2010 07:21 PM

    creynders's Avatar

    I did use v1.3.0. If I remember correctly I solved it by adding domain="current" to the the subpage node that fires up the context, which would mean it's rather a Gaia issue than RL, I think.

  3. creynders closed this discussion on 02 Nov, 2010 07:21 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac