Robot Legs/FlashBuilder 4

Jeremy Flowers's Avatar

Jeremy Flowers

17 Nov, 2010 10:17 AM

I tried downloading the zip file for the helloworld code yesterday.
Then I downloaded the latest source for robotlegs out of git, and built it with Maven, to generate the swf for the framework.
Then I changed the build path to reference that version of the swf.
But unfortunately Flash Builder 4 can't seem to detect the Context class. I'm a bit confused to these messages, because the org.robotlegs.mvcs.Context is clearly in the source folder and the startup method that the IDE also complains about is in that class.
What am I doing wrong?
See attached screenshot

  1. 1 Posted by Jeremy Flowers on 17 Nov, 2010 11:46 AM

    Jeremy Flowers's Avatar

    I managed to overcome that problem.. But now have another.
    I tweaked the RobotLegs build path, per the attached screenshot.
    But then hit an obstacle with:
    The style 'borderThickness' is only supported by type 'mx.containers.Form' with the theme(s) 'halo'. LoginPage.mxml /robotlegs-demos-HelloFlex/src/org/robotlegs/demos/helloflex/view line 25 Flex Problem
    See new attachment

  2. 2 Posted by Jeremy Flowers on 17 Nov, 2010 12:01 PM

    Jeremy Flowers's Avatar

    I've also tried adding the halo.swc file to my project
    Per the docs here:
    See attachment - I'm still having problems after having cleaned/built project.

  3. 3 Posted by Stray on 17 Nov, 2010 12:02 PM

    Stray's Avatar

    Are you using the 'spark' components theme? The message seems to suggest it needs 'halo'. I'm guessing this demo was put together in FB3 not 4.

  4. 4 Posted by Jeremy Flowers on 17 Nov, 2010 12:07 PM

    Jeremy Flowers's Avatar

    Hi Stray. I've ascertained this by adding the halo.swc - I do have the spark.swc in the build path too. Would you suggest removing spark.swc/sparkspins.swc?

  5. 5 Posted by Jeremy Flowers on 17 Nov, 2010 12:10 PM

    Jeremy Flowers's Avatar

    Well that idea didn't work either...
    Then I get an extra warning:

    The style 'dropShadowVisible' is only supported by type 'mx.controls.List' with the theme(s) 'spark'. robotlegs-demos-HelloFlex line 488 Flex Problem

  6. 6 Posted by Jeremy Flowers on 17 Nov, 2010 12:18 PM

    Jeremy Flowers's Avatar

    I ended up removing the border thickness attribute.
    This seemed to fix things.

  7. 7 Posted by Jeremy Flowers on 17 Nov, 2010 12:21 PM

    Jeremy Flowers's Avatar

    But then, when I run the app I get the context not found message at runtime...

  8. 8 Posted by Stray on 17 Nov, 2010 12:43 PM

    Stray's Avatar

    Hi Jeremy, I'm afraid I'm an as3 person, not a flex person - hence my slightly stupid question :) (Always worth asking these things though - all of us sometimes mis something right in front of us while looking for a more complex cause).

    There are some flex people on here so hopefully you'll get a flex-expert response shortly. Some is US based so you'll be waiting a few hours, but there are some uk folk, so if you're lucky then one will pick this up sooner.

  9. Support Staff 9 Posted by Ondina D.F. on 17 Nov, 2010 02:47 PM

    Ondina D.F.'s Avatar

    Hi Jeremy,

    I’ve tried the HelloFlex example with:

    FlashBuilder 4.0 / Flex SDK 4.0

    and with

    FlashBuilder Burrito / Flex Hero SDK

    with robotlegs.swc v.1.3.0 and 1.4.0

    and everything works just fine.

    In the files I have, there is no ‘borderThickness’. That means that you probably have an older demo file. That could be one of your problems.

    Maybe the best way to make it work is to delete the project (and the files on the hard disk containing the project’s settings and info) and replace it with the demo from here:

    First delete the robotlegs.swc in that folder (which is old!)
    copy the newest robotlegs.swc (1.4.0) and make sure you have just one robotlegs.swc in there
    and restart FlashBuilder

    It should work :)

    If it doesn’t work, then maybe your FlashBuilder’s configuration has changed somehow?
    Have you tried other robotlegs examples as well?


  10. 10 Posted by Jeremy Flowers on 17 Nov, 2010 02:53 PM

    Jeremy Flowers's Avatar

    Got there eventually..
    When I added to framework SWF I think I must have specified some of the configuration incorrectly. Now when project gets built the file gets copied into the bin-debug folder automatically.

  11. 11 Posted by Jeremy Flowers on 17 Nov, 2010 02:56 PM

    Jeremy Flowers's Avatar

    This was where I got the demo app from:

    Effectively you get here by running the demo and doing a view source in the web browser
    There is a link to download the source with the offending attribute on the tag.

  12. Stray closed this discussion on 11 Feb, 2011 05:20 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac