Export Release Build in Flash Builder

Tim Oxley's Avatar

Tim Oxley

18 Dec, 2009 06:00 AM

So everything works fine in my project for both "Run" & "Debug", but when I go to "Export Release Build" in Flash Builder Beta 2, then run my app, my dependencies don't appear to be injected, resulting in:

TypeError: Error #1009: Cannot access a property 
or method of a null object reference...

Any idea why this could be?

  1. Support Staff 1 Posted by Till Schneidere... on 18 Dec, 2009 10:35 AM

    Till Schneidereit's Avatar

    Sounds like Flash Builder doesn't adhere to the "-keep-as3-metadata" settings of SWCs when exporting release builds.

    Can you try adding the arguments as specified in the "Installation" section of SwiftSuspenders' readme?

  2. Support Staff 2 Posted by Shaun Smith on 18 Dec, 2009 04:21 PM

    Shaun Smith's Avatar

    Hmmm.. that's pretty crazy! I've exported plenty of release builds with Robotlegs and SwiftSuspenders. I just tried with an app published from FB4 build 262635 and everything worked properly. What version of Flash Builder are you running?

  3. 3 Posted by Tim Oxley on 20 Dec, 2009 11:14 PM

    Tim Oxley's Avatar


    So as per Till's instructions, adding the following to the compiler settings in Flash Builder 253292 seemed to get things working:


    I'll download the latest version of Flash Builder (which I thought I was running, but clearly not) and see how that goes.


    Though, Shaun perhaps the version numbers are different because you're on a Mac. Investigating.

  4. 4 Posted by Tim Oxley on 21 Dec, 2009 03:21 AM

    Tim Oxley's Avatar

    I am running the latest version of Flash Builder available from:



    So turns out, I am running a version of Swift Suspenders compiled from source and I did, in fact, forget to add the -keep-as3-metadata for the compile settings on this project. What's surprising is that even though I don't have the compile settings set up, it still works for Run / Debug.

    Now I WAS using a provided Swift Suspenders .swc before using one I compiled myself, so perhaps even though I've cleaned the whole eclipse workspace, for some reason the metadata info has stayed with the compiler, and only surfaces as a problem once I do a release build. Or something.
    Weird huh.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac