Mediator onRegister not called

O.M.'s Avatar


04 Jan, 2011 11:12 AM

In my context I have two views. The first view is the main flex-view for the component, which ahs the context declaration and it registers fine. However the second view does not register. I have not forgot ot mistyped the mediator.mapView() nor the override public function onRegister(). I have tried to shuffle the mapView() around in the context mapping list. The mapEvent's works fine. It is just that second view that does not register. I have tried to add the view to the displaylist both before and after the startup of the context, but nothing happens.

I just need some hints so I can start debugging this. I have two contexts in the site which works in their own scopes, but this shouldn't be any problem as I understand?

  1. 1 Posted by O.M. on 04 Jan, 2011 01:31 PM

    O.M.'s Avatar


    It never occured to me that all the context views must be a child of the main contextView.

  2. 2 Posted by Nikos on 06 Jan, 2011 01:21 PM

    Nikos 's Avatar

    please close discussion

  3. Till Schneidereit closed this discussion on 08 Jan, 2011 03:56 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac