base classes Injector and Reflector not found in Flash Builder 4

achim.bloch's Avatar


07 Jan, 2011 03:13 PM

I'm pretty new to RobotLegs, and I am experiencing something a bit weird :
when debug-running a simple app based on this tutorial :
the two RL base classes Injector and Reflector are not found.
I've tried both with the download and the GIT versions of the framework, but the problem still remains.
Could someone help?

  1. 1 Posted by achim.bloch on 07 Jan, 2011 03:46 PM

    achim.bloch's Avatar

    Solved. I hadn't added the swiftSuspenders framework to my project, as I thought it was a part of RL...

  2. achim.bloch closed this discussion on 07 Jan, 2011 03:47 PM.

  3. Gerry Koh re-opened this discussion on 07 Jan, 2011 05:25 PM

  4. 2 Posted by Gerry Koh on 07 Jan, 2011 05:25 PM

    Gerry Koh's Avatar

    Including SwiftSuspenders is only necessary if you are including the RL framework as source. If you are using the swc everything is packed in there.

  5. Stray closed this discussion on 11 Feb, 2011 11:14 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac