Hello Flash

lucas17169's Avatar


12 Jan, 2010 10:37 PM

Couldn't get the example to work (not that I have tried others). Could you guys add a zip file with a working version of the examples.

I don't really know how to use git, so would be great to have the files to see it all working.

Kind regards
Lucas Jones

  1. 1 Posted by Tim Oxley on 13 Jan, 2010 12:15 AM

    Tim Oxley's Avatar

    You've tried v1.0RC6 from http://github.com/robotlegs/robotlegs-demos-Bundle/downloads ?

    What problem did you have getting the example to work?

  2. 2 Posted by lucas17169 on 13 Jan, 2010 12:42 AM

    lucas17169's Avatar

    stopping here:

    TypeError: Error #1009: Cannot access a property or method of a null object reference.

    at org.robotlegs.base::EventMap/mapListener()[E:\workspace\flashAS3\external_projects\robotlegs.org\test\src\org\robotlegs\base\EventMap.as:102]
    at org.robotlegs.demos.helloflash.view::ReadoutMediator/onRegister()[E:\workspace\flashAS3\external_projects\robotlegs.org\test\src\org\robotlegs\demos\helloflash\view\ReadoutMediator.as:46]
    at org.robotlegs.base::MediatorBase/preRegister()[E:\workspace\flashAS3\external_projects\robotlegs.org\test\src\org\robotlegs\base\MediatorBase.as:66]
    at org.robotlegs.base::MediatorMap/registerMediator()[E:\workspace\flashAS3\external_projects\robotlegs.org\test\src\org\robotlegs\base\MediatorMap.as:163]
    at org.robotlegs.base::MediatorMap/createMediator()[E:\workspace\flashAS3\external_projects\robotlegs.org\test\src\org\robotlegs\base\MediatorMap.as:148]
    at org.robotlegs.base::MediatorMap/onViewAdded()[E:\workspace\flashAS3\external_projects\robotlegs.org\test\src\org\robotlegs\base\MediatorMap.as:263]
    at flash.display::DisplayObjectContainer/addChild()
    at org.robotlegs.demos.helloflash::HelloFlashContext/startup()[E:\workspace\flashAS3\external_projects\robotlegs.org\test\src\org\robotlegs\demos\helloflash\HelloFlashContext.as:60]
    at org.robotlegs.mvcs::Context/checkAutoStartup()[E:\workspace\flashAS3\external_projects\robotlegs.org\test\src\org\robotlegs\mvcs\Context.as:213]
    at org.robotlegs.mvcs::Context()[E:\workspace\flashAS3\external_projects\robotlegs.org\test\src\org\robotlegs\mvcs\Context.as:77]
    at org.robotlegs.demos.helloflash::HelloFlashContext()[E:\workspace\flashAS3\external_projects\robotlegs.org\test\src\org\robotlegs\demos\helloflash\HelloFlashContext.as:41]
    at HelloFlash()[E:\workspace\flashAS3\external_projects\robotlegs.org\test\src\HelloFlash.as:36]

    [SWF] E:\workspace\flashAS3\external_projects\robotlegs.org\test\bin-debug\HelloFlash.swf - 49.805 bytes after decompression

  3. Support Staff 3 Posted by Ondina D.F. on 13 Jan, 2010 10:39 AM

    Ondina D.F.'s Avatar

    Hey Lucas,
    Maybe it’s the same issue like the one discussed here:
    Flex 3 Modules Example - Factory Widget

  4. Support Staff 4 Posted by Shaun Smith on 13 Jan, 2010 06:12 PM

    Shaun Smith's Avatar

    Hi Lucas,

    Apologies if you have done all this already, just double-checking.

    Download the latest Demo Bundle ZIP here:


    And the latest Robotlegs SWC:


    Your Flex/Flash Builder project will need to have a "libs" folder set as a SWC folder as described in:


    Finally, make sure that you don't have both the Robotlegs and SwiftSuspenders SWC files linked to the same project - I believe this can cause issues.

    If, after all that, it's still not working, please let us know what version of Flash/Flex Builder you are using, and the version of the Flex SDK that you are compiling against.

    Oh dear, I just had a thought.. Are you compiling against the Robotlegs source code (ie, simply including the Robotlegs source in the demo projects, instead of linking against the Robotlegs SWC)? Compiling against the source requires 2 compiler arguments as described over at:



    Linking against the SWC will do this for you automagically. Flex/Flash Builder is a little annoying in that it will create a "libs" folder for Flex projects, but not for plain ActionScript projects (you have to create the folder and point at it manually).

    I'm pretty sure using the SWC or including the compiler arguments will sort out your issue. Let us know how it goes.

  5. 5 Posted by lucas17169 on 17 Jan, 2010 03:48 AM

    lucas17169's Avatar

    Hi Shaun.

    Thank you very much for you kind reply.

    My only problem at the end was I didn't know about the compiling paramiter as I was using both sources (no SWCs).

    All I did was, inside flexbuilder 3, right click project root folder -> properties -> ActionScript Compiler -> the added the following line inside Additional compiler arguments:

    -keep-as3-metadata+=Inject -keep-as3-metadata+=PostConstruct

    that was it... up and running.


  6. Till Schneidereit closed this discussion on 02 Mar, 2010 12:46 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac