Modular Robotlegs not working online - Module's startup() method within the context never gets fired

derekrosien's Avatar


19 May, 2011 03:01 PM

Hey guys!

First off, I am really new to Robotlegs... But LOVE it...

I am trying to make a fairly complex project with a lot going on in the start up... All is working great when testing within Flashbuilder but as soon as I test online, none of the contexts are starting in my modules...

I have made a simple project to confirm this, just a basic sample that I started from with the Mediators of each module writing to a text area...

Again, running within Flashbuilder everything registers and triggers and all is wired up perfectly, but as soon as I get it online it stops... It seems like the module's context's startup() method never gets fired at all and therefore the Mediator never gets mapped and the mediator's onRegister() method never gets fired.

If someone could help me out that would be a huge help... I kinda banked on the fact that when it was working great in Flashbuilder that it would work when I tested online but that was not the case this morning...

Thanks for the help if anyone can steer me in the right direction!

A demo of what it is not doing online can be found here

I have also attached the FXP for this simple demo.

Thanks again!


  1. 1 Posted by derekrosien on 19 May, 2011 03:05 PM

    derekrosien's Avatar

    Not sure if this attachment will be posted...

    Says ( Processing Asset)

    Here is a link off of my server

    Thanks again!


  2. Support Staff 2 Posted by Stray on 25 May, 2011 08:07 AM

    Stray's Avatar

    Hi Derek - sorry you didn't get helped with this faster, did you get a solution? If not, shout and we'll dig into it - you caught us at a busy time.

    What version of FP were you testing with?


  3. 3 Posted by derekrosien on 25 May, 2011 11:44 AM

    derekrosien's Avatar

    Nope never got any updates as of yet... Been really racking my brain on this one... Any help at this point would be great!!!

    I am still using the preview release of Burrito ( haven't had the time to install the final release that I upgraded to )...

    I am also trying to publish using the SDK ( the latest public release )...

    I am also part of the beta program with the 4.5 SDK but have yet to try it on any of those builds as of yet. Again, haven't had the time to uninstall the preview release of Burrito and worked from there...

    What I did figure out though was that if I removed the Mediator on the main class ( removing the mapping of the Main.mxml to the class ) this actually worked...

    But I obviously need the MainMediator... ( there is nothing in this demo one at the moment )...

    I have also tried to publish with different SDKs with the same results... I haven't tried to publish in FlashBuilder 4 though...

    What do you think?

    Its strange that it is all working in Flashbuilder but craps out as soon as you put it online...

    I have basically taken all of this off of the DynModules example

    What do you think?


  4. 4 Posted by derekrosien on 25 May, 2011 11:46 AM

    derekrosien's Avatar
  5. 5 Posted by Stray on 25 May, 2011 12:05 PM

    Stray's Avatar

    Hi Derek,

    I don't use flashBuilder but there have been a few occasions on the forum where FB has been the culprit.

    I *was* going to suggest that perhaps your release build was stripping the metadata from the shell? But the whole remove/add mediator from your main app fixes things part doesn't make a lot of sense.

    If there's some sort of 'clean' you can do on the project, give that a go. Otherwise I'll see if someone can take a look in FB.


  6. 6 Posted by derekrosien on 25 May, 2011 12:56 PM

    derekrosien's Avatar

    Yeah I have cleaned plenty of times... Pretty much every time I change something.

    Is there a quick way to test with some sort of command line builder? Like an ANT script or something that will compile the project?

    Sorry, but I am not all that familiar with using the command line to publish projects...

    If it comes down to having to do this for release builds I am fine with that and just continue on testing within Flashbuilder as this is working fine when debugging.


  7. 7 Posted by derekrosien on 25 May, 2011 01:39 PM

    derekrosien's Avatar

    GOT IT!!!

    Did a search for "release builds are stripping out the robotlegs metadata"

    Found this post:

    Adding the following to the compiler arguments in Flashbuilder works perfectly in my test example and my main project as well!

    -keep-as3-metadata+=Inject -keep-as3-metadata+=PostConstruct

    Thanks for the help in starting me down the trail of FB stripping out the Metadata...


  8. 8 Posted by Stray on 25 May, 2011 01:58 PM

    Stray's Avatar


  9. derekrosien closed this discussion on 25 May, 2011 02:22 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac