Issues debugging a View component

nkatakam's Avatar


22 Jul, 2011 05:24 PM


I am facing a strange issue, where i am not able to hit a break point in one of my view component. Basically I have a file structure like

  • View
    • Component 1
    • Component 2

The view is controlled by a mediator and has not business logic within it. But component 1 and component 2 are already existing controls which have a buch of business logic with in them. I am modifying these components through the view mediator, i.e. if i want to set any propert in component 1, in the view 1 mediator i am refereing it to as view1.comp1.prop1.

I want to debug through my component 1 but i am not able to setup any break points within it. Is it because there is not direct reference to Component 1 and I am accessing it through its a view mediator?

I have compiled my entire app and ensured that I have the latest swf's. Also I ran pkill -f fdb to kill my flash debugger, non of them worked.

I use intellij 10 for my flex development, so not sure if this is their issue.

I am new to robot legs and wanted to know whether this is the actual reason for this issue.

Thank you,


  1. Support Staff 1 Posted by Ondina D.F. on 02 Nov, 2011 04:55 PM

    Ondina D.F.'s Avatar

    Hi Niki,
    Just wanted to let you know, that, for some reason, there was a spam filter issue on the robotlegs forum. That’s why a few posts were visible on the list, but couldn’t be opened, therefore they got no answers.
    Your post was one of them. Sorry for the inconvenience!!
    Have you found an answer to your question by now?

  2. Ondina D.F. closed this discussion on 16 Nov, 2011 09:13 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac