Getting a "Internal build error" when using Robotlegs

Christen's Avatar


03 Aug, 2011 07:28 AM


I'm working on a fairly large project. The project has been created by someone else and is more a prototype than anything else. I am now trying to change this code into something that makes more sense (useing: Robotlegs and Signals). Unfortunately I can't refactor the code, but have to change it while keeping the code running.

I have put robotlegs arround the old "framework", and change the old files one by one, but sometimes I get this error: "An internal build error has occurred. Right-click for more information." in Flash Builder (More info:, log says: null Pointer error)

When I comment out a mediatorMap.mapView from the context and bild, the error disapears, Then I can uncomment it again and it works again for a while.

Any ideas, as of how to solve this bug?

  1. 1 Posted by Michal Wroblews... on 03 Aug, 2011 07:53 AM

    Michal Wroblewski's Avatar

    Are you using Robotlegs as a SWC or source files?

  2. Support Staff 2 Posted by Ondina D.F. on 03 Aug, 2011 08:24 AM

    Ondina D.F.'s Avatar

    Hi Christen,

    I remember getting this kind of error in FlexBuilder3, due to an empty switch statement!
    Also external libraries (swc) can be the issue. It’s a nasty error, sometimes hard to find.

    I would try to run the project without robotlegs first.
    If the error disappears, the next questions are:

    Do you have more than one view from that external project, that you are mapping?
    If yes, is only one view causing this issue?
    Are you loading the project as an swc?

    Can you show a snippet of your mappings?

    Oh, I see, Mike has already answered:)


  3. 3 Posted by Christen on 03 Aug, 2011 08:57 AM

    Christen's Avatar


    I am using robotlegs as sourcefiles, because I was having problems with the SWC.

    But I am using signals-extension-SignalCommandMap.swc and SwiftSuspenders-v1.5.1.swc

    But I am not sure if they ar nesesary or are insluded in the robotlegs framework.

    I'm using FB 4

    If I am not using Robotlegs, signals asf. I works fine. (Or it did, right now it will not work at all)

  4. 4 Posted by Michal Wroblews... on 03 Aug, 2011 09:37 AM

    Michal Wroblewski's Avatar

    Check if there are any errors like this using Robotlegs SWC.

    If not try adding these lines to the compilator:


    And here you can get a similar topic:


  5. Support Staff 5 Posted by Ondina D.F. on 03 Aug, 2011 09:38 AM

    Ondina D.F.'s Avatar
    • if you use the robotlegs swc, swiftsuspenders is already included in the framework library
    • if you use the robotlegs src, then you need the swiftsuspenders src as well. Maybe you already know that in this case you need to add -keep-as3-metadata+=Inject -keep-as3-metadata+=PostConstruct to the compiler arguments, for the release build
    • if the project works fine without robotlegs+swiftsuspenders+ signals-extension-SignalCommandMap, then I guess the way you are linking the libraries is the problem( Flex Build Path), or
    • if you fixed it in your build path, and you have just robotlegs.swc and signals-extension-SignalCommandMap and it still doesn’t work, then maybe signals-extension-SignalCommandMap is the culprit. I can’t help you with that, but maybe it’s an old version?
    • also try to Clean the project, see if any debugger instances are still running, close the project, delete the settings and start anew .

    Maybe Mike has some suggestions as well. Sorry for interfering, actually.


  6. 6 Posted by Stray on 03 Aug, 2011 09:40 AM

    Stray's Avatar

    Hi Christen - I just wanted to add that "changing the code while keeping things working" is the definition of refactoring - so you *can* and *are* doing refactoring. Breaking stuff isn't refactoring!

    I'm guessing you don't have automated tests? I'd recommend adding end-to-end tests for the key functionality if possible - that way you know that you are preserving what works.


    On 3 Aug 2011, at 10:56, Christen wrote:


  7. 7 Posted by Christen on 23 Aug, 2011 08:54 AM

    Christen's Avatar

    Sorry for late replys.

    Had some vecation and forgot about it.

    I don't know what happend, but I stoped getting the error. I think it was because I was using some classes both in the old and new framework. Now I am making good progress converting the whole project to robotlegs and signals.

    Att: Stray and refactoring: I know. It's a longer story. But the product is unstable while I am converting it, and other people are using it as I worked on it. Fortunaly I have some time to fix it now in a new branch.

  8. Ondina D.F. closed this discussion on 01 Nov, 2011 11:42 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac