Can't map view with mediator in flex mobile project

foodyi's Avatar


16 Apr, 2014 10:42 AM

when i debug the project in simulator or device , rl2 works well. after export the project to IPA file and install it to my iPhone
i found mediator had never been triggered , when the view add to the stage. ( i listen the addToStage event, i am sure i had been triggered)
i had added compile args -keep-as3-metadata+=Inject -keep-as3-metadata+=PostConstruct ,is there anyone encounter this issue? or has experiences on developing flex mobile project with rl2?

my env : flash builder4.7
sdk: apache flex 4.11 air4.0 test device: Iphone4s.

  1. Support Staff 1 Posted by Ondina D.F. on 16 Apr, 2014 11:15 AM

    Ondina D.F.'s Avatar


    I guess you're using the ASC2 compiler. See the links to the github issues mentioned in this discussion:

    Same question to you: have you tried compiling against the robotlegs swc instead of the source?


  2. 2 Posted by foodyi on 17 Apr, 2014 01:09 AM

    foodyi's Avatar

    hi Ondina
    I had tried to compile project with rl2 swc instead of source, it doesn't work either.
    but when i compile my project with rl1 and export ipa, it works well on my iPhone.
    i guess something wrong with rl2 or new version of SwiftSuspenders.

  3. Support Staff 3 Posted by Ondina D.F. on 17 Apr, 2014 11:09 AM

    Ondina D.F.'s Avatar

    Hmmm, that's not good, and I have no idea how to help you, because I'm not using the new compiler. Sorry! Hopefully, you'll get some answers from others, who might have experience with ASC2.

    Have you tried to build a (simple) desktop application with robotlegs 2 in your new dev environment (apache flex 4.11 air4.0)? Does it work as a release build?

    Are you, by any chance, using some other library/framework too (like Starling)? If the answer is yes, could you try to build a very simple app (only one view + one mediator), using only rl2, and see if you encounter the same issues?

    Are you using the latest robotlegs 2 version?

  4. Ondina D.F. closed this discussion on 05 Jun, 2014 04:38 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac