problem with signals

jonniebigodes's Avatar


03 Jul, 2013 11:43 PM

i don't know if this is the correct place for this thread. if not please redirect it.

i've discovered robotlegs awhile ago, been fiddling it with. and now came the time to update to v2.
So the problem is this. i've been trying to add signals to robotlegs 2. and i came up dry. i grabbed the robotlegs.swc, grabbed as3-signals-v0.9-BETA.swc, and the SignalCommandMap extension, added them to my libs folder. and flashbuilder 4.6 gives out this error:
unable to load SWC as3-signals-v0.9-BETA.swc

tried to implement on a air 3.5 project, same error. tried it with the default flex sdk that comes with flashbuilder 4.6, same problem
Help would be appreciated
thanks in advance

  1. Support Staff 1 Posted by Ondina D.F. on 04 Jul, 2013 07:32 AM

    Ondina D.F.'s Avatar

    Hi Jonnie,

    see if this works:

    with rl 2.1.0 :

    Let us know how it goes.


  2. 2 Posted by jonniebigodes on 04 Jul, 2013 08:38 AM

    jonniebigodes's Avatar

    hi. my problem is with signals itself. the extension signalcommandmap loads up nice. only the as3-signals doesn't. gives out the error i posted in here. and i posted the problem here, because i read that the code was ported to robotlegs.

  3. Support Staff 3 Posted by Ondina D.F. on 04 Jul, 2013 08:43 AM

    Ondina D.F.'s Avatar

    Try this example to see if it works:

  4. Support Staff 4 Posted by Ondina D.F. on 04 Jul, 2013 11:10 AM

    Ondina D.F.'s Avatar

    I’ve tried the example myself in FlashBuilder 4.6 AIR SDK 3.7, and all worked well.

    If you want I can attach the libs I used.

  5. 5 Posted by jonniebigodes on 04 Jul, 2013 12:27 PM

    jonniebigodes's Avatar

    i've overlayed the sdk. added air 3.7. created a project to run with that sdk. so far so good. when i go to Properties/Flex Build Path/Library Path/ add SWC and try to add as3-signals-v0.9-BETA.swc the error pops up, if i remove and start by adding robotlegs-extensions-SignalCommandMap-v1.0.0b1. the same problem occurs.
    i went and tried to add it directly, by copying the as3-signals-v0.9-BETA.swc and robotlegs-extensions-SignalCommandMap-v1.0.0b1 to the libs folder on my project and flasbuilder throws me the same error.

  6. Support Staff 6 Posted by Ondina D.F. on 04 Jul, 2013 12:48 PM

    Ondina D.F.'s Avatar

    Yeah, I also tried to use the robotlegs-extensions-SignalCommandMap-v1.0.0b1, and something went wrong. Then I used the source code of SignalCommandMap, and it worked fine. I changed the todo example to work with the new libs and the SignalCommandMap source. If you want I can attach it.

  7. 7 Posted by jonniebigodes on 04 Jul, 2013 01:43 PM

    jonniebigodes's Avatar

    i would appreciate if you attach the source.

  8. Support Staff 8 Posted by Ondina D.F. on 04 Jul, 2013 01:59 PM

    Ondina D.F.'s Avatar

    Here you go.

  9. Support Staff 9 Posted by Ondina D.F. on 09 Jul, 2013 01:46 PM

    Ondina D.F.'s Avatar

    I assume you solved your problem. I'm closing this discussion, but feel free to re-open it , if need be.

  10. Ondina D.F. closed this discussion on 09 Jul, 2013 01:46 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac