Building Robotlegs 2

mbarjawi's Avatar


30 Jul, 2012 07:18 AM

I am sorry if this is a dump question... but I couldn't find any information on how to build Robotlegs 2.

I downloaded the zip file from git, extracted it, and attempted to "Import Flash Builder Project" but the folder wasn't recognized as a Flash Builder project.

Looking again at the git page, it says "Using ANT: ant package"... which didn't make sense to me as I never used ANT.

I checked the forums but no answers there too... so I downloaded ant, installed it on my machine, and I can run "ant -version" and see the result successfully. Now the question is:

How to I build Robotlegs 2?

Thanks for the help :)

  1. 1 Posted by Michal Wroblews... on 30 Jul, 2012 07:29 AM

    Michal Wroblewski's Avatar


    Building by ANT is I think the simplest one. Just download ANT binaries. Then add ANT paths to the system command line (google for "install ant on (windows or mac)". Then open your robotlegs folder in the command line and just type ant. Then it should run all the test and build the project.

  2. 2 Posted by mbarjawi on 30 Jul, 2012 07:37 AM

    mbarjawi's Avatar

    Thanks a lot Michal... you beat me to the answer :)

    It was a dump question after all...
    Using the command line, I navigated to the extracted Robotlegs 2 folder, typed: ant
    that was it... :)

    However, I didn't have the "FLEX_HOME" variable in my environment variables, to I added that and made it point to my Flex SDK 4.6.

    Now, the other problem that I faced is when it is trying to build, it starts showing some lines with the [flexunit] tag, it continues little bit but then fails with "socket timeout".. here is a snapshot of whats going on.

    [flexunit] Executing 'rundll32' with arguments:
    [flexunit] 'url.dll,FileProtocolHandler'
    [flexunit] 'G:\Barjawi\Workplace\FlexProjects\robotlegs-robotlegs-framework\bin\TestRunner.swf'
    [flexunit] The ' characters around the executable and arguments are
    [flexunit] not part of the command.
    [flexunit] Stopping server ...
    [flexunit] End of test data reached, sending acknowledgement to player ...
    [flexunit] Closing client connection ...
    [flexunit] Closing server on port [1024] ...
    G:\Barjawi\Workplace\FlexProjects\robotlegs-robotlegs-framework\build.xml:99: java.util.concurrent.ExecutionException: Socket timeout waiting for flexunit report
    at java.util.concurrent.FutureTask$Sync.innerGet(

    I tried turning off my firewall and trying again, but same result.

    Now my questions:

    • how to fix this?

    • if this is just a test that failed... then does this mean the robotlegs swc built is a success?

    Thanks for the help

  3. 3 Posted by Michal Wroblews... on 30 Jul, 2012 07:52 AM

    Michal Wroblewski's Avatar

    To fix this problem run tests with debug flash player version. Just download any debug player version (if you don't have one) and open flash player (it shall set this executable as default). Then run the ant again. If you get this again you can just skip test part of ant script calling "ant compile"


  4. 4 Posted by mbarjawi on 31 Jul, 2012 03:35 AM

    mbarjawi's Avatar

    ant compile worked for me. I tried downloading Flash Player 11.3 Projector content debugger, ran the application, it opened the flash player window... but still the ant command didn't finish the tests.

    I also tried installing the FP 11.3 ActiveX control content debugger for IE, same results as before.

    I am happy with only compiling the RL2... however, it is annoying that I cannot get it to fully run the tests... any other quick suggestions?


  5. 5 Posted by Michal Wroblews... on 31 Jul, 2012 07:56 AM

    Michal Wroblewski's Avatar

    Can you try opening any swf file and check if it's a debugger or release version of Flash Player (default player) If not you have to make any Debug version a default one.

    Also can you check what version (debug or release) of Flash Player is opened during the test? There should be small window opened.

  6. 6 Posted by mbarjawi on 02 Aug, 2012 09:50 AM

    mbarjawi's Avatar

    That worked perfectly...

    I attempted to open a swf, which prompted me to select a default application, once I selected the debugger version and ran that swf, I attempted ant again and it worked successfully.

    Thanks you so much.

  7. mbarjawi closed this discussion on 02 Aug, 2012 09:50 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac